Development Blog

  • macos

    25 Sep
    sierra apache homebrew php
    Special Edition: macOS 10.14 Mojave Web Development Environment

    This is a guide to help those with prior Homebrew mutliple PHP-based installations that are looking to upgrade to the new Hombrew/core PHP setup from the prior Homebrew/php keg which is now deprecated.

    With the deprecation o...

  • macos

    25 Sep
    sierra apache homebrew php

    [Updated 4/6/2018] Due to Homebrew/php tap being deprecated at the end of March 2018, and the moving of all PHP formulas to Homebrew/core, we've reworked our Guide to work with this new tap.

    If you have followed this guide in the past with the Homebrew/php tap, and are looking to upgrade to the new Homebrew/core approach, then you should first clean-up your current installation by following our new Upgrading Homebrew.

    Part 1: macOS 10.14 Mojave Web Development Environment

    This is an updated version of our prior OS X development series. The newly released macOS 10.14 Mojave and the accompanying updates to Brew require significant changes compared to prior releases, necessitating a thorough revamp in the process. Since macOS 10.12 we now use Homebrew's Apache, rather than the built-in version, but this new appraoch is more flexible and should continue to work on prior OS X versions.

    Developing web applications on macOS is a real joy. There are plenty of options for setting up your development environments, including the ever-popular MAMP Pro that provides a nice UI on top of Apache, PHP and MySQL. However, there are times when MAMP Pro has slow downs, or out of date versions, or is simply behaving badly due to its restrictive system of configuration templates and non-standard builds.

    It is times like these that people often look for an alternative approach, and luckily there is one, and it is relatively straight-forward to setup.

    In this blog post, we will walk you through setting up and configuring Apache 2.4 and multiple PHP versions. In the second blog post in this two-post series, we will cover MySQL, Apache virtual hosts, APC caching, and Xdebug installation.

  • journal

    24 Mar
    php

    TL;DR - Grav 1.5 will require PHP 5.6.4, while Grav 1.6 will require PHP 7.1.3

    When Grav 1.0 was officially released Dec 11th, 2015, the minimum requirements were PHP 5.4. PHP 5.4 was by far the most popular PHP version in use at the time, and so it was an appropriate baseline during initia...

  • journal

    21 Dec
    php

    We have decided to change the minimum requirements for Grav from PHP 5.4.40 to 5.5.9 to stay in line with the new minimum version of some of our key vendor libraries.

    As is typical with these kinds of things, We launched Grav 1.0 right around the same time that PHP 7.0 was released, and everything seemed great. Even though Grav runs amazingly on PHP 7.0 there are some PHP 7.0 compatibility issues within some of the vendor libraries that Grav relies upon.

    These external libraries are continually updated and have started dropping support for older EOL (End of Life) versions of PHP. In order to continue using the latest versions of these libraries and support the new PHP 7.0, we need to keep our requirements in line with our key libraries. Grav currently supports PHP 5.4 which was an actively supported version when we started developing Grav, but is no longer supported according to the PHP Supported Versions document.