Raising PHP Requirements... Again

What's planned for Grav 1.7 and beyond...

1 minute

TL;DR - Grav 1.7 will require PHP 7.3.6

The last time we announced PHP version changes was back in March of 2018. Back then, we made a massive jump for minimal PHP requirements from PHP 5.6.4 to PHP 7.1.3. We've enjoyed being on a more modern version of PHP for the Grav 1.6 release, and as we have been working on Grav 1.7 for well over a year now, the libraries we want to use require a higher version of PHP. We had originally planned to raise the limit to 7.2, but that version is about to end security support within a couple of weeks. PHP 7.3 continues has another few weeks of active support, and then it enters security support for another year. With PHP 8.0 being released November 26, 2020, it makes sense for us to up our requirements to currently supported versions and say we will fully support Grav 1.7 running on PHP 7.3, 7.4 and 8.0

PHP Support

Grav 1.7

Moving to PHP 7.3.6 for the minimum requirement for Grav 1.7 means we can continue to use more modern and more robust PHP syntax and functionality. It also means we can update our core-libraries to the latest and greatest versions that still maintain backwards compatibility. As Symfony is a framework we are using more of in Grav 1.7, this bump in requirements means we can move to the latest most feature-rich Symfony 5.1 stable release. Many of our other vendor libraries will also be able to be updated during the release cycle of Grav 1.7 to address stability and security as needed.

Grav 2.0

While Grav 2.0 is still very much in active discussion with the community, we can be pretty sure that the minimum requirements for it will be at least PHP 8.0.