Changing PHP Requirements to 5.5

A tough choice that had to be made immediately

1 min

We have decided to change the minimum requirements for Grav from PHP 5.4.40 to 5.5.9 to stay in line with the new minimum version of some of our key vendor libraries.

As is typical with these kinds of things, We launched Grav 1.0 right around the same time that PHP 7.0 was released, and everything seemed great. Even though Grav runs amazingly on PHP 7.0 there are some PHP 7.0 compatibility issues within some of the vendor libraries that Grav relies upon.

These external libraries are continually updated and have started dropping support for older EOL (End of Life) versions of PHP. In order to continue using the latest versions of these libraries and support the new PHP 7.0, we need to keep our requirements in line with our key libraries. Grav currently supports PHP 5.4 which was an actively supported version when we started developing Grav, but is no longer supported according to the PHP Supported Versions document.

PHP 5.5 is the oldest supported version and will receive security updates until July of 2016 when it also reaches it's end of life.

We have added logic in the current build of Grav and the Grav Admin so that GPM will warn you if you are running Grav on PHP 5.4 that the next updated requires PHP 5.5.9. Also the problems plugin will also warn you if you are running on PHP 5.4.

Grav 1.0.5 will be the last version of Grav that can is supported by PHP 5.4. Grav version 1.0.6 and newer versions will require PHP 5.5.9 or newer.

Download 1.0.5 from GitHub

We strongly suggest you update PHP as soon as possible to continue to get the latest and greatest Grav updates.